Taller de Informática

Funciones

USO DE FUNCIONES EN LA HOJA DE CÁLCULO

Una función es una fórmula especial que ya está escrita y que acepta un valor o valores, que realiza una operación y devuelve un valor o valores. Las funciones pueden utilizarse solas o como componentes para construir fórmulas más extensas.

Por ejemplo, en lugar de escribir la fórmula = A1+A2+A3+A4

Puede utilizar la función SUMA para construir la fórmula =SUMA(A1:A4)

Para usar las funciones las debe introducir en las fórmulas. La secuencia de caracteres utilizada para introducir una función válida se llama sintaxis. Todas las funciones tienen la misma sintaxis. Todos los argumentos se colocan entre paréntesis, los argumentos individuales dentro de los paréntesis se separan usando punto y coma (;) y los rangos de argumentos con dos puntos (:).

La siguiente ilustración es un ejemplo de una función y su sintaxis

=SUMA(2;13;50;37)

Signo igual (si la función se encuentra al inicio de la fórmula)

Nombre de la función.

Los argumentos están encerrados entre paréntesis.

Un punto y coma separa cada argumento.

Pautas para el uso de funciones:

Los paréntesis indican a Excel dónde comienzan y dónde terminan los argumentos. No olvide incluir ambos paréntesis, sin dejar espacios antes ni después de cada uno de ellos.

No use puntos para separar los miles para los valores numéricos. Use el formato número para determinar cómo se presentan los valores resultantes.

Los argumentos se especifican dentro de los paréntesis de una función. Éstos pueden ser números, referencias, texto, valores lógicos, matrices o valores de error.

Los argumentos de una fusión pueden ser valores constantes o fórmulas. Si usa una fórmula, ésta puede contener otras funciones. Cuando el argumento de una función es una función, se trata de una función anidada. En Excel, es posible anidar hasta siete niveles de funciones en una fórmula.

Mensajes de error:

Si Excel presenta un mensaje indicando que hay un error en la función o en la fórmula, asegúrese de que:

Todos los paréntesis coincidan.

Todos los argumentos necesarios estén en orden y sean del tipo de datos requeridos. Si omite un argumento, escriba una coma como marcador de lugar.

Uso del botón “Autosuma”

La función SUMA es la función para hojas de cálculo que se utiliza con mayor frecuencia. Con ella puede transformar una fórmula compleja como =A2+A3+A4+A5+A6 en una forma más concisa =SUMA(A2:A6). El botón “Autosuma” en la barra de herramientas Estándar es aún más conveniente. Cuando usa el botón “Autosuma”, Excel escribe la función y hasta sugiere el rango de celdas que desea agregar.

Se debe tener en cuenta que el rango de datos que precede a la celda en donde se realizará la autosuma debe ser continuo y con datos (todos) numericos.

Introducir una fórmula de suma con el botón “Autosuma”

Para introducir una fórmula de suma, seleccione una celda adyacente a una fila o columna de números que desee agregar y haga clic en el botón “Autosuma” en la barra de herramientas Estándar.

Funciones estadísticas

Función SUMA

La función SUMA permite efectuar la suma de un conjunto de números. Esta función puede contener hasta 30 argumentos.

Su sintaxis es :

=SUMA(Argumentos)

Argumentos :

=SUMA(12;34;76;45)

=SUMA(A1:D8)

=SUMA(A1:D8 ;A10 :D20)

=SUMA(A1;A2;A3)

Función PROMEDIO

La función PROMEDIO permite efectuar el promedio a un conjunto de números.

Su sintaxis es :

=PROMEDIO(Argumentos)

Argumentos :

=PROMEDIO(12 ;34 ;56 ;43)

=PROMEDIO(A1 :D8)

=PROMEDIO(A1 :D8 ;A10 :D20)

=PROMEDIO(A1 ;A2 ;A3)

Funciones MIN y MAX

MIN : Devuelve el valor mínimo de un conjunto de números.

MAX : Devuelve el valor máximo de un conjunto de números.

Su sintaxis es :

=MIN(Argumentos)

=MAX(Argumentos)

Funciones Matemáticas

Mediante las funciones matemáticas pueden ejecutarse cálculos matemáticos simples y complejos, como el cálculo del valor total de un rango de celdas, el del valor total de una rango de celdas que cumplan una condición en otro rango o redondear números.

Función ENTERO

Redondea un número hasta el entero inferior más próximo.

Su Sintaxis es:

=ENTERO(número)

Donde número es el número real que desea redondear al entero inferior más próximo.

Ejemplo:

Se en la celda A1 el contenido es 1023,56

El resultado de la función =ENTERO(A1) es igual a 1023

Función Redondear

Redondea un número al número de decimales especificado.

Sintaxis:

=REDONDEAR(número;núm_de_decimales)

Número es el número que desea redondear.

Núm_de_decimales especifica el número de dígitos al que desea redondear el argumento número.

Si el argumento núm_de_decimales es mayor que 0 (cero), número se redondeará al número de lugares decimales especificado.

Si el argumento núm_de_decimales es 0, número se redondeará al entero más próximo.

Si el argumento núm_de_decimales es menor que 0, número se redondeará hacia la izquierda del separador decimal.

Ejemplos :

=REDONDEAR(2,15; 1) es igual a 2,2

=REDONDEAR(2,149; 1) es igual a 2,1

=REDONDEAR(-1,475; 2) es igual a -1,48

=REDONDEAR(21,5; -1) es igual a 20

Función ABS

Esta función devuelve el valor absoluto de un numero (o sea el valor positivo de un número negativo).

Sintaxis :

=ABS(número)

Ejemplo:

=ABS(-15326) es igual a 15326

Funciones lógicas

Habitualmente las funciones lógicas se usan para precisar si una condición es verdadera o de lo contrario si es falsa.

Pruebas Condicionales

Se definen las pruebas condicionales como expresiones que comparan números, funciones, rótulos o valores lógicos. Cada una de las pruebas condicionales debe contener un operador lógico.

=A1>A2

=5-3<5*2

=PROMEDIO(B1 :B6)=SUMA(6 ;7 ;8)

=C2=”Paisaje”

La función SI

Esta función se utiliza para poder evaluar una condición que involucra determinadas celdas y valores. Dependiendo de que dicha condición sea verdadera o falsa será el resultado de la función.

Sintaxis :

=SI(Prueba_lógica ;Valor_si_verdadero ;Valor_si_falso)

Los posibles valores para Valor_si_verdadero y Valor_si _falso son los siguientes :

Una constante numérica.

Una constante alfanumérica.

Una fórmula.

Una función.

Una función SI.

Función SI anidadas

Esta función se utiliza cuando no es viable solucionar dificultades aplicando los operadores lógicos y las funciones Y, O y NO. Esta función SI anidada admite un escala jerárquica de pruebas. El máximo de funciones a anidar son 7, y que no supere el límite de 255 caracteres en un celda.

Ejemplo :

Supongamos que en las celdas A1 y B2 se indican valores de temperatura y humedad. La función SI anidada nos dará las combinaciones que se indican más abajo.

Consideremos la función :

=SI(A1>20 ;SI(B2<70 ;”Caluroso sin humedad” ;”Caluroso con humedad”) ;”Fresco”)

Valor de la celda A1        Valor de la celda B2            Resultado de la Función

21                                 50                                     Caluroso sin humedad

21                                 80                                     Caluroso con humedad

17                                 Cualquier valor numérico    Fresco

Funciones de Fecha

Las funciones de fecha nos proporcionan un método rápido de realizar calculos con las mismas y de obtener ciertos datos.

Función HOY

Devuelve la fecha actual del sistema dependiendo de la configuración de facha y hora de Windows, esto significa que si el resultado es una fecha distinta a la del día, hay que modificar la misma desde el Panel de Control de Windows.

Sintáxis :

=HOY()

Funciones DIA, MES y AÑO

Devuelven un número que representa el día, el mes o el año de la fecha indicada.

Sintáxis :

=DIA(Fecha)

=MES(Fecha)

=AÑO(Fecha)

Ejemplo: Supongamos que la fecha del sistema es 15 de mayo del 2001.

=DIA(HOY()) es igual a 15

=MES(HOY()) es igual a 5

=AÑO(HOY()) es igual a 2001

Función DIAS360

Devuelve la cantidad de días que transcurrieron entre dos fechas basándose en años de 360 días, por lo que el resultado no será exacto.

Sintáxis :

=DIAS360(Fecha menos actual;Fecha mas actual)

Ejemplo :

=DIAS360(“01/01/2001″;”15/05/2001”) es igual a 134

Función DIASEM

Devuelve el numero de día de la semana de la fecha indicada, pudiendo resultar de 1 (domingo) a 7 (sábado).

Sintáxis :

=DIASEM(Fecha)

Ejemplo :

=DIASEM(“28/05/2001”) es igual a 2 (lunes)

Función AHORA

Es muy similar a HOY, con la diferencia que también devuelve la hora del sistema.

Sintáxis :

=AHORA()

Ejemplo: Supongamos que la fecha del sistema es 15 de mayo del 2001 y son las 10 y media en punto.

=Ahora() es igual a 15/05/2001 10:30:00

Funciones HORA, MINUTO y SEGUNDO

Son similares a DIA, MES y AÑO pero con la hora del sistema

Sintáxis :

=HORA(Hora)

=MINUTO(Hora)

=SEGUNDO(Hora)

Ejemplos:

=HORA(AHORA()) es igual a 10

=MINUTO(AHORA()) es igual a 30

=SEGUNDO(AHORA()) es igual a 0

2 comentarios »

  1. no tenes la funcion buscarrrrrrrrrrrrrrrrrrrrrr!!!!!!!!!!!!!

    Comentario por mica rammauro — 2 septiembre 2011 @ 21:46 | Responder

    • Para que tenés el cuaderno de claseeeeeeeee!!!

      Comentario por profegalasso — 3 septiembre 2011 @ 1:54 | Responder


RSS feed for comments on this post. TrackBack URI

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Crea un blog o un sitio web gratuitos con WordPress.com.

A %d blogueros les gusta esto: